Intermittent issues saving updates
Incident Report for Elevio
Resolved
This incident has been resolved.
Posted Aug 20, 2017 - 20:40 AEST
Identified
We're currently having intermittent issues in saving updates from your dashboard, we're continuing to investigate the issue.
In the mean time, your content is still being served to your users via the embeddable without issue.
Posted Aug 20, 2017 - 11:51 AEST